In short
- CVE-2025-11362 is a HIGH (CVSS 7.5) vulnerability affecting pdfmake (pdfmake), pdfmake.
- Chance of exploitation in the next 30 days (EPSS): 0.43%, higher than 37.4% of all vulnerabilities.
- Fix: update to 0.3.0-beta.17 or later.
| Package | Affected versions | Patched versions |
|---|
| pdfmake | = 0.3.0
| No fix yet |
| pdfmake npm | ≥ 0.3.0-beta.1, < 0.3.0-beta.17
| 0.3.0-beta.17
|
Description
Versions of the package pdfmake from 0.3.0-beta.1 to before 0.3.0-beta.17 are vulnerable to Allocation of Resources Without Limits or Throttling via repeatedly redirect URL in file embedding. An attacker can cause the application to crash or become unresponsive by providing crafted input that triggers this condition.
NVD description
Versions of the package pdfmake from 0.3.0-beta.1 and before 0.3.0-beta.17 are vulnerable to Allocation of Resources Without Limits or Throttling via repeatedly redirect URL in file embedding. An attacker can cause the application to crash or become unresponsive by providing crafted input that triggers this condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free