In short
- CVE-2026-26801 is a HIGH (CVSS 7.5) vulnerability affecting pdfmake (pdfmake), pdfmake.
- Chance of exploitation in the next 30 days (EPSS): 0.55%, higher than 46.0% of all vulnerabilities.
- Fix: update to 0.3.6 or later.
| Package | Affected versions | Patched versions |
|---|
| pdfmake | = 0.3.0≥ 0.3.1, ≤ 0.3.5
| No fix yet |
| pdfmake npm | ≥ 0.3.0-beta.2, < 0.3.6
| 0.3.6
|
Description
Server-Side Request Forgery (SSRF) vulnerability in pdfmake versions 0.3.0-beta.2 through 0.3.5 allows a remote attacker to obtain sensitive information via the src/URLResolver.js component. The fix was released in version 0.3.6 which introduces the setUrlAccessPolicy() method allowing server operators to define URL access rules. A warning is now logged when pdfmake is used server-side without a policy configured.
NVD description
Server-Side Request Forgery (SSRF) vulnerability in pdfmake versions 0.3.0-beta.2 through 0.3.5 allows a remote attacker to obtain sensitive information via the src/URLResolver.js component. The fix was released in version 0.3.6 which introduces the setUrlAccessPolicy() method allowing server operators to define URL access rules. A warning is now logged when pdfmake is used server-side without a policy configured.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free