In short
- CVE-2025-13281 is a MEDIUM (CVSS 5.8) vulnerability affecting k8s.io/kubernetes.
- Chance of exploitation in the next 30 days (EPSS): 0.39%, higher than 33.0% of all vulnerabilities.
- Fix: update to 1.33.6, 1.34.2, 1.32.10 or later.
| Package | Affected versions | Patched versions |
|---|
| k8s.io/kubernetes Go | ≥ 1.33.0-alpha.0, < 1.33.6≥ 1.34.0-alpha.0, < 1.34.2< 1.32.10
| 1.33.61.34.21.32.10
|
Description
A half-blind Server Side Request Forgery (SSRF) vulnerability exists in kube-controller-manager when using the in-tree Portworx StorageClass. This vulnerability allows authorized users to leak arbitrary information from unprotected endpoints in the control plane’s host network (including link-local or loopback services).
NVD description
A half-blind Server Side Request Forgery (SSRF) vulnerability exists in kube-controller-manager when using the in-tree Portworx StorageClass. This vulnerability allows authorized users to leak arbitrary information from unprotected endpoints in the control plane’s host network (including link-local or loopback services).
More vulnerabilities in k8s.io/kubernetes
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free