In short
- CVE-2025-5187 is a MEDIUM (CVSS 6.7) vulnerability affecting k8s.io/kubernetes.
- Chance of exploitation in the next 30 days (EPSS): 0.57%, higher than 47.4% of all vulnerabilities.
- Fix: update to 1.32.8, 1.33.4, 1.31.12 or later.
| Package | Affected versions | Patched versions |
|---|
| k8s.io/kubernetes Go | ≥ 1.32.0-alpha.0, < 1.32.8≥ 1.33.0-alpha.0, < 1.33.4< 1.31.12
| 1.32.81.33.41.31.12
|
Description
A vulnerability exists in the NodeRestriction admission controller in Kubernetes clusters where node users can delete their corresponding node object by patching themselves with an OwnerReference to a cluster-scoped resource. If the OwnerReference resource does not exist or is subsequently deleted, the given node object will be deleted via garbage collection.
NVD description
A vulnerability exists in the NodeRestriction admission controller in Kubernetes clusters where node users can delete their corresponding node object by patching themselves with an OwnerReference to a cluster-scoped resource. If the OwnerReference resource does not exist or is subsequently deleted, the given node object will be deleted via garbage collection.
More vulnerabilities in k8s.io/kubernetes
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free