In short
- CVE-2025-2953 is a MEDIUM (CVSS 5.5) vulnerability affecting torch, pytorch (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.26%, higher than 17.8% of all vulnerabilities.
- Fix: update to 2.7.1-rc1 or later.
| Package | Affected versions | Patched versions |
|---|
| torch PyPI | ≤ 2.6.0+cu124< 2.7.1-rc1
| 2.7.1-rc1
|
| pytorch | = 2.6.0+cu124
| No fix yet |
Description
A vulnerability, which was classified as problematic, has been found in PyTorch 2.6.0+cu124. Affected by this issue is the function torch.mkldnn_max_pool2d. The manipulation leads to denial of service. An attack has to be approached locally. The exploit has been disclosed to the public and may be used.
NVD description
A vulnerability, which was classified as problematic, has been found in PyTorch 2.6.0+cu124. Affected by this issue is the function torch.mkldnn_max_pool2d. The manipulation leads to denial of service. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. The real existence of this vulnerability is still doubted at the moment. The security policy of the project warns to use unknown models which might establish malicious effects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free