In short
- CVE-2025-2999 is a MEDIUM (CVSS 5.3) vulnerability affecting torch, pytorch (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.20%, higher than 10.1% of all vulnerabilities.
- Fix: update to 2.9.1 or later.
| Package | Affected versions | Patched versions |
|---|
| torch PyPI | ≤ 2.6.0-NA< 2.9.1
| 2.9.1
|
| pytorch | = 2.6.0
| No fix yet |
Description
A vulnerability was found in PyTorch 2.6.0. It has been rated as critical. Affected by this issue is the function torch.nn.utils.rnn.unpack_sequence. The manipulation leads to memory corruption. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used.
A patch is available through commit 4945180.
NVD description
A vulnerability was found in PyTorch 2.6.0. It has been rated as critical. Affected by this issue is the function torch.nn.utils.rnn.unpack_sequence. The manipulation leads to memory corruption. Attacking locally is a requirement. The exploit has been disclosed to the public and may be used.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free