In short
- CVE-2025-30741 is a MEDIUM (CVSS 4.3) vulnerability affecting pixelfed/pixelfed.
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 24.5% of all vulnerabilities.
- Fix: update to 0.12.5 or later.
Description
Pixelfed before 0.12.5 allows anyone to follow private accounts and see private posts on other Fediverse servers. This affects users elsewhere in the Fediverse, if they otherwise have any followers from a Pixelfed instance.
NVD description
Pixelfed before 0.12.5 allows anyone to follow private accounts and see private posts on other Fediverse servers. This affects users elsewhere in the Fediverse, if they otherwise have any followers from a Pixelfed instance.
More vulnerabilities in pixelfed/pixelfed
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free