In short
- CVE-2025-46148 is a MEDIUM (CVSS 5.3) vulnerability affecting torch, pytorch (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.40%, higher than 34.4% of all vulnerabilities.
- Fix: update to 2.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| torch PyPI | < 2.7.0
| 2.7.0
|
| pytorch | ≤ 2.6.0
| No fix yet |
Description
In PyTorch through 2.6.0, when eager is used, nn.PairwiseDistance(p=2) produces incorrect results.
NVD description
In PyTorch through 2.6.0, when eager is used, nn.PairwiseDistance(p=2) produces incorrect results.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free