In short
- CVE-2025-46152 is a MEDIUM (CVSS 5.3) vulnerability affecting torch, pytorch (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.45%, higher than 39.3% of all vulnerabilities.
- Fix: update to 2.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| torch PyPI | ≥ 2.6.0, < 2.7.0
| 2.7.0
|
| pytorch | ≥ 2.6.0, < 2.7.0
| 2.7.0
|
Description
In PyTorch before 2.7.0, bitwise_right_shift produces incorrect output for certain out-of-bounds values of the "other" argument.
NVD description
In PyTorch before 2.7.0, bitwise_right_shift produces incorrect output for certain out-of-bounds values of the "other" argument.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free