In short
- CVE-2025-46153 is a MEDIUM (CVSS 5.3) vulnerability affecting torch, pytorch (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.42%, higher than 36.2% of all vulnerabilities.
- Fix: update to 2.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| torch PyPI | ≥ 2.6.0, < 2.7.0
| 2.7.0
|
| pytorch | ≥ 2.6.0, < 2.7.0
| 2.7.0
|
Description
PyTorch before 3.7.0 has a bernoulli_p decompose function in decompositions.py even though it lacks full consistency with the eager CPU implementation, negatively affecting nn.Dropout1d, nn.Dropout2d, and nn.Dropout3d for fallback_random=True.
NVD description
PyTorch before 3.7.0 has a bernoulli_p decompose function in decompositions.py even though it lacks full consistency with the eager CPU implementation, negatively affecting nn.Dropout1d, nn.Dropout2d, and nn.Dropout3d for fallback_random=True.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free