In short
- CVE-2025-50151 is a HIGH (CVSS 8.8) vulnerability affecting org.apache.jena:jena, jena (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 64.8% of all vulnerabilities.
- Fix: update to 5.5.0 or later.
Description
File access paths in configuration files uploaded by users with administrator access are not validated.
This issue affects Apache Jena version up to 5.4.0.
Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
NVD description
File access paths in configuration files uploaded by users with administrator access are not validated.
This issue affects Apache Jena version up to 5.4.0.
Users are recommended to upgrade to version 5.5.0, which does not allow arbitrary configuration upload.
More vulnerabilities in org.apache.jena:jena
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free