In short
- CVE-2025-6278 is a CRITICAL (CVSS 9.8) vulnerability affecting upsonic, upsonic (upsonic).
- Chance of exploitation in the next 30 days (EPSS): 0.70%, higher than 53.3% of all vulnerabilities.
- Fix: update to 0.56.0 or later.
| Package | Affected versions | Patched versions |
|---|
| upsonic PyPI | < 0.56.0
| 0.56.0
|
| upsonic | ≤ 0.55.6
| No fix yet |
Description
A vulnerability classified as critical was found in Upsonic up to 0.55.6. This vulnerability affects the function os.path.join of the file markdown/server.py. The manipulation of the argument file.filename leads to path traversal. The exploit has been disclosed to the public and may be used.
NVD description
A vulnerability classified as critical was found in Upsonic up to 0.55.6. This vulnerability affects the function os.path.join of the file markdown/server.py. The manipulation of the argument file.filename leads to path traversal. The exploit has been disclosed to the public and may be used.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free