In short
- CVE-2025-6279 is a HIGH (CVSS 8.0) vulnerability affecting upsonic, upsonic (upsonic).
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 43.4% of all vulnerabilities.
- Fix: update to 0.56.0 or later.
| Package | Affected versions | Patched versions |
|---|
| upsonic PyPI | < 0.56.0
| 0.56.0
|
| upsonic | ≤ 0.55.6
| No fix yet |
Description
A vulnerability, which was classified as critical, has been found in Upsonic up to 0.55.6. This issue affects the function cloudpickle.loads of the file /tools/add_tool of the component Pickle Handler. The manipulation leads to deserialization. The exploit has been disclosed to the public and may be used.
NVD description
A vulnerability, which was classified as critical, has been found in Upsonic up to 0.55.6. This issue affects the function cloudpickle.loads of the file /tools/add_tool of the component Pickle Handler. The manipulation leads to deserialization. The exploit has been disclosed to the public and may be used.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free