In short
- CVE-2025-64529 is a MEDIUM (CVSS 6.5) vulnerability affecting github.com/authzed/spicedb, spicedb (authzed).
- Chance of exploitation in the next 30 days (EPSS): 0.26%, higher than 18.3% of all vulnerabilities.
- Fix: update to 1.45.2 or later.
Description
Impact
Users who
- use the exclusion operator somewhere in their authorization schema
- have configured their SpiceDB server such that
--write-relationships-max-updates-per-call is bigger than 6500
- issue calls to WriteRelationships with a large enough number of updates that cause the payload to be bigger than what their datastore allows
will
- receive a successful response from their
WriteRelationships call, when in reality that call failed,
- receive incorrect permission check results, if those relationships had to be read to resolve the relation involving the exclusion
Patches
Upgrade to v.145.2.
Workarounds
Set --write-relationships-max-updates-per-call to 1000.
NVD description
SpiceDB is an open source database system for creating and managing security-critical application permissions. In versions prior to 1.45.2, users who use the exclusion operator somewhere in their authorization schema; have configured their SpiceDB server such that `--write-relationships-max-updates-per-call` is bigger than 6500; and issue calls to WriteRelationships with a large enough number of updates that cause the payload to be bigger than what their datastore allows; will receive a successful response from their `WriteRelationships` call, when in reality that call failed, and receive incorrect permission check results, if those relationships had to be read to resolve the relation involving the exclusion. Version 1.45.2 contains a patch for the issue. As a workaround, set `--write-relationships-max-updates-per-call` to `1000`.
More vulnerabilities in github.com/authzed/spicedb
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free