In short
- CVE-2025-66675 is a HIGH (CVSS 8.2) vulnerability affecting org.apache.struts:struts2-core, struts (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.59%, higher than 48.4% of all vulnerabilities.
- Fix: update to 6.8.0, 7.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.struts:struts2-core Maven | ≥ 2.0.0, < 6.8.0≥ 7.0.0, < 7.1.1
| 6.8.07.1.1
|
| struts | ≥ 2.0.0, ≤ 2.3.37≥ 2.5.0, ≤ 2.5.33≥ 6.0.0, < 6.8.0≥ 7.0.0, < 7.1.1
| 6.8.07.1.1
|
Description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
NVD description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion.
This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3.
Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
It's related to https://cve.org/CVERecord?id=CVE-2025-64775 - this CVE addresses missing affected version 6.7.4
More vulnerabilities in org.apache.struts:struts2-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free