In short
- CVE-2025-67221 is a HIGH (CVSS 7.5) vulnerability affecting orjson, orjson (ijl).
- Chance of exploitation in the next 30 days (EPSS): 0.63%, higher than 50.5% of all vulnerabilities.
- Fix: update to 3.11.5, 3.11.6 or later.
| Package | Affected versions | Patched versions |
|---|
| orjson PyPI | < 3.11.5< 3.11.6
| 3.11.53.11.6
|
| orjson | ≤ 3.11.4
| No fix yet |
Description
The orjson.dumps function in orjson before 3.11.6 does not limit recursion for deeply nested JSON documents.
NVD description
The orjson.dumps function in orjson thru 3.11.4 does not limit recursion for deeply nested JSON documents.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free