In short
- CVE-2025-67640 is a MEDIUM (CVSS 5.0) vulnerability affecting org.jenkins-ci.plugins:git-client, git client (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.21%, higher than 11.6% of all vulnerabilities.
- Fix: update to 6.4.1 or later.
Description
Jenkins Git client Plugin 6.4.0 and earlier does not not correctly escape the path to the workspace directory as part of an argument in a temporary shell script generated by the plugin, allowing attackers able to control the workspace directory name to inject arbitrary OS commands.
NVD description
Jenkins Git client Plugin 6.4.0 and earlier does not not correctly escape the path to the workspace directory as part of an argument in a temporary shell script generated by the plugin, allowing attackers able to control the workspace directory name to inject arbitrary OS commands.
More vulnerabilities in org.jenkins-ci.plugins:git-client
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free