In short
- CVE-2025-67716 is a MEDIUM (CVSS 5.7) vulnerability affecting nextjs-auth0 (auth0), @auth0/nextjs-auth0.
- Chance of exploitation in the next 30 days (EPSS): 0.26%, higher than 18.1% of all vulnerabilities.
- Fix: update to 4.12.1, 4.13.0 or later.
Description
Description
An input-validation flaw in the returnTo parameter in the Auth0 Next.js SDK could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters
Am I Affected?
You are affected if you meet the following preconditions:
- Applications using the auth0/nextjs-auth0 SDK version prior to 4.13.0
Affected product and versions
Auth0/nextjs-auth0 versions >= 4.9.0 and < 4.13.0
Resolution
Upgrade Auth0/nextjs-auth0 version to v4.13.0
Acknowledgements
Okta would like to thank Joshua Rogers (MegaManSec) for their discovery and responsible disclosure.
NVD description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions 4.9.0 through 4.12.1 contain an input-validation flaw in the returnTo parameter, which could allow attackers to inject unintended OAuth query parameters into the Auth0 authorization request. Successful exploitation may result in tokens being issued with unintended parameters. This issue is fixed in version 4.13.0.
More vulnerabilities in nextjs-auth0
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free