In short
- CVE-2026-40155 is a MEDIUM (CVSS 5.4) vulnerability affecting nextjs-auth0 (auth0), @auth0/nextjs-auth0.
- Chance of exploitation in the next 30 days (EPSS): 0.21%, higher than 11.8% of all vulnerabilities.
- Fix: update to 4.18.0 or later.
Description
Description
In affected versions of the Next.js SDK, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results.
Which Projects are Affected?
Users are affected if they meet all of the following preconditions:
- Applications using the auth0/nextjs-auth0 SDK, versions 4.12.0 to 4.17.0, and
- Applications using the proxy handler /me/* and /my-org/* with DPoP enabled.
Affected product and versions
Auth0/nextjs-auth0 v4.12.0 to 4.17.0
Resolution
Upgrade Auth0/nextjs-auth0 version to v4.18.0 or greater
Acknowledgements
Okta would like to thank Reynaldo Immanuel for their discovery and responsible disclosure.
NVD description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.
More vulnerabilities in nextjs-auth0
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free