In short
- CVE-2026-115324 is a HIGH (CVSS 8.1) vulnerability affecting mem0ai.
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 25.2% of all vulnerabilities.
- Fix: update to 1.0.8 or later.
| Package | Affected versions | Patched versions |
|---|
| mem0ai PyPI | ≥ 0.1.117, < 1.0.8
| 1.0.8
|
Description
mem0 0.1.117 before 1.0.8 contains an sql injection vulnerability in mem0/vector_stores/databricks.py that allows attackers to inject SQL by influencing stored memory content. Attackers can supply crafted memory text, metadata, or message names that reach unescaped insert() and update() string interpolation to execute injected SQL on the configured Databricks SQL warehouse.
NVD description
mem0 0.1.117 before 1.0.8 contains an sql injection vulnerability in mem0/vector_stores/databricks.py that allows attackers to inject SQL by influencing stored memory content. Attackers can supply crafted memory text, metadata, or message names that reach unescaped insert() and update() string interpolation to execute injected SQL on the configured Databricks SQL warehouse.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free