In short
- CVE-2026-7597 is a MEDIUM (CVSS 6.3) vulnerability affecting mem0ai.
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 24.5% of all vulnerabilities.
- Fix: update to 2.0.0b2 or later.
| Package | Affected versions | Patched versions |
|---|
| mem0ai PyPI | < 2.0.0b2
| 2.0.0b2
|
Description
A vulnerability was found in mem0ai mem0 up to 1.0.11. This affects the function pickle.load/pickle.dump of the file mem0/vector_stores/faiss.py. Performing a manipulation results in deserialization. It is possible to initiate the attack remotely. The exploit has been made public and could be used. The patch is named 62dca096f9236010ca15fea9ba369ba740b86b7a. Applying a patch is the recommended action to fix this issue.
NVD description
A vulnerability was found in mem0ai mem0 up to 1.0.11. This affects the function pickle.load/pickle.dump of the file mem0/vector_stores/faiss.py. Performing a manipulation results in deserialization. It is possible to initiate the attack remotely. The exploit has been made public and could be used. The patch is named 62dca096f9236010ca15fea9ba369ba740b86b7a. Applying a patch is the recommended action to fix this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free