In short
- CVE-2026-24512 is a HIGH (CVSS 8.8) vulnerability affecting k8s.io/ingress-nginx.
- Chance of exploitation in the next 30 days (EPSS): 0.55%, higher than 46.0% of all vulnerabilities.
- Fix: update to 1.14.3, 1.13.7 or later.
| Package | Affected versions | Patched versions |
|---|
| k8s.io/ingress-nginx Go | ≥ 1.14.0, < 1.14.3< 1.13.7all versions
| 1.14.31.13.7
|
Description
A security issue was discovered in ingress-nginx. Tthe rules.http.paths.path Ingress field can be used to inject configuration into nginx. This can lead to arbitrary code execution in the context of the ingress-nginx controller, and disclosure of Secrets accessible to the controller. (Note that in the default installation, the controller can access all Secrets cluster-wide.)
NVD description
A security issue was discovered in ingress-nginx where the `rules.http.paths.path` Ingress field can be used to inject configuration into nginx. This can lead to arbitrary code execution in the context of the ingress-nginx controller, and disclosure of Secrets accessible to the controller. (Note that in the default installation, the controller can access all Secrets cluster-wide.)
More vulnerabilities in k8s.io/ingress-nginx
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free