In short
- CVE-2026-24514 is a MEDIUM (CVSS 6.5) vulnerability affecting k8s.io/ingress-nginx.
- Chance of exploitation in the next 30 days (EPSS): 0.52%, higher than 43.9% of all vulnerabilities.
- Fix: update to 1.14.3, 1.13.7 or later.
| Package | Affected versions | Patched versions |
|---|
| k8s.io/ingress-nginx Go | ≥ 1.14.0, < 1.14.3< 1.13.7all versions
| 1.14.31.13.7
|
Description
A security issue was discovered in ingress-nginx where the validating admission controller feature is subject to a denial of service condition. By sending large requests to the validating admission controller, an attacker can cause memory consumption, which may result in the ingress-nginx controller pod being killed or the node running out of memory.
NVD description
A security issue was discovered in ingress-nginx where the validating admission controller feature is subject to a denial of service condition. By sending large requests to the validating admission controller, an attacker can cause memory consumption, which may result in the ingress-nginx controller pod being killed or the node running out of memory.
More vulnerabilities in k8s.io/ingress-nginx
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free