In short
- CVE-2026-27119 is a MEDIUM (CVSS 5.4) vulnerability affecting svelte (svelte), svelte.
- Chance of exploitation in the next 30 days (EPSS): 0.21%, higher than 11.3% of all vulnerabilities.
- Fix: update to 5.51.5 or later.
| Package | Affected versions | Patched versions |
|---|
| svelte | ≥ 5.39.3, < 5.51.5
| 5.51.5
|
| svelte npm | ≥ 5.39.3, < 5.51.5
| 5.51.5
|
Description
In certain circumstances, the server-side rendering output of an <option> element does not properly escape its content, potentially allowing HTML injection in the SSR output. Client-side rendering is not affected.
NVD description
svelte performance oriented web framework. From 5.39.3, <=5.51.4, in certain circumstances, the server-side rendering output of an <option> element does not properly escape its content, potentially allowing HTML injection in the SSR output. Client-side rendering is not affected. This vulnerability is fixed in 5.51.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free