In short
- CVE-2026-29194 is a HIGH (CVSS 8.1) vulnerability affecting github.com/gravitl/netmaker, netmaker (gravitl).
- Chance of exploitation in the next 30 days (EPSS): 0.47%, higher than 40.9% of all vulnerabilities.
- Fix: update to 1.5.0 or later.
Description
The Authorise middleware in Netmaker incorrectly validates host JWT tokens. When a route permits host authentication (hostAllowed=true), a valid host token bypasses all subsequent authorisation checks without verifying that the host is authorised to access the specific requested resource. Any entity possessing knowledge of object identifiers (node IDs, host IDs) can craft a request with an arbitrary valid host token to access, modify, or delete resources belonging to other hosts. Affected endpoints include node info retrieval, host deletion, MQTT signal transmission, fallback host updates, and failover operations.
Credits
Artem Danilov (Positive Technologies)
NVD description
Netmaker makes networks with WireGuard. Prior to version 1.5.0, the Authorize middleware in Netmaker incorrectly validates host JWT tokens. When a route permits host authentication (hostAllowed=true), a valid host token bypasses all subsequent authorization checks without verifying that the host is authorized to access the specific requested resource. Any entity possessing knowledge of object identifiers (node IDs, host IDs) can craft a request with an arbitrary valid host token to access, modify, or delete resources belonging to other hosts. Affected endpoints include node info retrieval, host deletion, MQTT signal transmission, fallback host updates, and failover operations. This issue has been patched in version 1.5.0.
More vulnerabilities in github.com/gravitl/netmaker
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free