In short
- CVE-2026-29195 is a MEDIUM (CVSS 6.5) vulnerability affecting github.com/gravitl/netmaker, netmaker (gravitl).
- Chance of exploitation in the next 30 days (EPSS): 0.26%, higher than 17.8% of all vulnerabilities.
- Fix: update to 1.5.0 or later.
Description
The user update handler (PUT /api/users/{username}) lacks validation to prevent an admin-role user from assigning the super-admin role during account updates. While the code correctly blocks an admin from assigning the admin role to another user, it does not include an equivalent check for the super-admin role.
Credits
Artem Danilov (Positive Technologies)
NVD description
Netmaker makes networks with WireGuard. Prior to version 1.5.0, the user update handler (PUT /api/users/{username}) lacks validation to prevent an admin-role user from assigning the super-admin role during account updates. While the code correctly blocks an admin from assigning the admin role to another user, it does not include an equivalent check for the super-admin role. This issue has been patched in version 1.5.0.
More vulnerabilities in github.com/gravitl/netmaker
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free