In short
- CVE-2026-30226 is a HIGH (CVSS 7.5) vulnerability affecting devalue (svelte), devalue.
- Chance of exploitation in the next 30 days (EPSS): 0.42%, higher than 36.0% of all vulnerabilities.
- Fix: update to 5.6.4 or later.
| Package | Affected versions | Patched versions |
|---|
| devalue | < 5.6.4
| 5.6.4
|
| devalue npm | < 5.6.4
| 5.6.4
|
Description
In devalue v5.6.3, devalue.parse and devalue.unflatten were susceptible to prototype pollution via maliciously crafted payloads. Successful exploitation could lead to Denial of Service (DoS) or type confusion.
NVD description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. In devalue v5.6.3 and earlier, devalue.parse and devalue.unflatten were susceptible to prototype pollution via maliciously crafted payloads. Successful exploitation could lead to Denial of Service (DoS) or type confusion. This vulnerability is fixed in 5.6.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free