In short
- CVE-2026-42570 is a HIGH (CVSS 7.5) vulnerability affecting devalue (svelte), devalue.
- Chance of exploitation in the next 30 days (EPSS): 0.40%, higher than 33.9% of all vulnerabilities.
- Fix: update to 5.8.1 or later.
| Package | Affected versions | Patched versions |
|---|
| devalue | ≥ 5.6.3, < 5.8.1
| 5.8.1
|
| devalue npm | ≥ 5.6.3, < 5.8.1
| 5.8.1
|
Description
devalue.parse could, due to quirks in some JavaScript engines, be convinced to allocate much more memory than was needed when deserializing sparse arrays, leading to excessive memory consumption.
NVD description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From version 5.6.3 to before version 5.8.1, devalue.parse could, due to quirks in some JavaScript engines, be convinced to allocate much more memory than was needed when deserializing sparse arrays, leading to excessive memory consumption. This issue has been patched in version 5.8.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free