In short
- CVE-2026-38991 is a HIGH (CVSS 8.8) vulnerability affecting cockpit-hq/cockpit.
- Chance of exploitation in the next 30 days (EPSS): 0.38%, higher than 31.5% of all vulnerabilities.
- Fix: update to 2.14.0 or later.
Description
Cockpit versions 2.13.5 and earlier are affected by a misconfiguration within the Bucket component _isFileTypeAllowed function where a specially crafted filename bypasses an extension filter. This allows an authenticated attacker to rename arbitrary files with the .php file extension enabling arbitrary code to be executed on the underlying server.
NVD description
Cockpit 2.13.5 and earlier is affected by a misconfiguration within the Bucket component _isFileTypeAllowed function where a specially crafted filename bypasses an extension filter. This allows an authenticated attacker to rename arbitrary files with the .php file extension enabling arbitrary code to be executed on the underlying server.
More vulnerabilities in cockpit-hq/cockpit
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free