In short
- CVE-2026-38993 is a MEDIUM (CVSS 6.5) vulnerability affecting cockpit-hq/cockpit.
- Chance of exploitation in the next 30 days (EPSS): 0.84%, higher than 57.7% of all vulnerabilities.
- Fix: update to 2.14.0 or later.
Description
Cockpit 2.13.5 and earlier is vulnerable to directory traversal via the Buckets component. This vulnerability allows authenticated attackers to write files to arbitrary locations within the uploads directory or overwrite assets with malicious versions.
NVD description
Cockpit 2.13.5 and earlier is vulnerable to directory traversal via the Buckets component. This vulnerability allows authenticated attackers to write files to arbitrary locations within the uploads directory or overwrite assets with malicious versions.
More vulnerabilities in cockpit-hq/cockpit
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free