In short
- CVE-2026-42402 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.neethi:neethi, neethi (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.71%, higher than 53.6% of all vulnerabilities.
- Fix: update to 3.2.2 or later.
Description
Apache Neethi is vulnerable to a Denial of Service attack through algorithmic complexity in policy normalization. Specially crafted WS-Policy documents can trigger an exponential Cartesian cross-product expansion during the normalization process, causing unbounded memory allocation that exhausts the JVM heap. This occurs when the normalization process generates an excessive number of policy alternatives without bounds, leading to runtime memory exhaustion.
Users should upgrade to 3.2.2 which limits the maximum number of normalized policy alternatives.
NVD description
Apache Neethi is vulnerable to a Denial of Service attack through algorithmic complexity in policy normalization. Specially crafted WS-Policy documents can trigger an exponential Cartesian cross-product expansion during the normalization process, causing unbounded memory allocation that exhausts the JVM heap. This occurs when the normalization process generates an excessive number of policy alternatives without bounds, leading to runtime memory exhaustion.
Users should upgrade to 3.2.2 which limits the maximum number of normalized policy alternatives.
More vulnerabilities in org.apache.neethi:neethi
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free