In short
- CVE-2026-42403 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.neethi:neethi, neethi (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.76%, higher than 55.4% of all vulnerabilities.
- Fix: update to 3.2.2 or later.
Description
Apache Neethi does not properly detect circular references in policy definitions. When a WS-Policy document contains circular policy references (where Policy A references Policy B which references Policy A), the policy normalization process can enter an infinite loop or cause excessive recursion, leading to a stack overflow or application hang. An attacker can craft malicious policy documents with circular references to cause a Denial of Service condition
Users are recommended to upgrade to version 3.2.2, which fixes this issue.
NVD description
Apache Neethi does not properly detect circular references in policy definitions. When a WS-Policy document contains circular policy references (where Policy A references Policy B which references Policy A), the policy normalization process can enter an infinite loop or cause excessive recursion, leading to a stack overflow or application hang. An attacker can craft malicious policy documents with circular references to cause a Denial of Service condition
Users are recommended to upgrade to version 3.2.2, which fixes this issue.
More vulnerabilities in org.apache.neethi:neethi
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free