In short
- CVE-2026-53673 is a HIGH (CVSS 8.1) vulnerability affecting buddypress/buddypress.
- Chance of exploitation in the next 30 days (EPSS): 0.37%, higher than 31.1% of all vulnerabilities.
- Fix: update to 14.5.0 or later.
Description
BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the messages REST API that allows authenticated attackers to access arbitrary private message threads by supplying a user_id parameter in the request. Attackers can pass another user's identifier to the get_item_permissions_check method, which validates the supplied user_id instead of the logged-in user and is reused by the update and delete handlers, to read, reply to, or delete any user's private messages.
NVD description
BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the messages REST API that allows authenticated attackers to access arbitrary private message threads by supplying a user_id parameter in the request. Attackers can pass another user's identifier to the get_item_permissions_check method, which validates the supplied user_id instead of the logged-in user and is reused by the update and delete handlers, to read, reply to, or delete any user's private messages.
More vulnerabilities in buddypress/buddypress
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free