In short
- CVE-2026-94444 is a HIGH (CVSS 7.8) vulnerability affecting toolchain.
- Chance of exploitation in the next 30 days (EPSS): 0.10%, higher than 0.72% of all vulnerabilities.
- Fix: update to 1.27.2, 1.26.9 or later.
| Package | Affected versions | Patched versions |
|---|
| toolchain Go | ≥ 1.27.0-0, < 1.27.2< 1.26.9
| 1.27.21.26.9
|
Description
Previously, a user operating inside of a malicious Go project that defines a bogus golang.org/fips140 and operates a malicious GOMODPROXY the user chooses to connect to can serve an arbitrary module in its place.
We now unpack the trusted ziphash for the bundled golang.org/fips140 module and construct its entry in the GOMODCACHE such that it can be verified by the toolchain.
NVD description
Previously, a user operating inside of a malicious Go project that defines a bogus golang.org/fips140 and operates a malicious GOMODPROXY the user chooses to connect to can serve an arbitrary module in its place. We now unpack the trusted ziphash for the bundled golang.org/fips140 module and construct its entry in the GOMODCACHE such that it can be verified by the toolchain.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free