Kurz gesagt
- CVE-2019-1010275 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in helm.sh/helm, helm (helm).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 1.4%, höher als bei 71.7% aller Schwachstellen.
- Abhilfe: auf 2.7.2, 2.7.2+incompatible oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| helm.sh/helm Go | < 2.7.2< 2.7.2+incompatible
| 2.7.22.7.2+incompatible
|
| helm | < 2.7.2
| 2.7.2
|
Description
helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.
NVD description
helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free