Kurz gesagt
- CVE-2023-0870 ist eine Schwachstelle (MITTEL (CVSS 6.7)) in org.opennms:opennms-webapp, horizon (opennms), meridian (opennms).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.30%, höher als bei 23.3% aller Schwachstellen.
- Abhilfe: auf 31.0.6, 2020.1.33, 2021.1.25, 2022.1.14 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| org.opennms:opennms-webapp Maven | < 31.0.6
| 31.0.6
|
| horizon | < 31.0.6
| 31.0.6
|
| meridian | = 2023.1.0≥ 2020.1.0, < 2020.1.33≥ 2021.1.0, < 2021.1.25≥ 2022.1.0, < 2022.1.14
| 2020.1.332021.1.252022.1.14
|
Description
A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
NVD description
A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free