Kurz gesagt
- CVE-2023-25170 ist eine Schwachstelle (HOCH (CVSS 8.8)) in prestashop/prestashop, prestashop (prestashop).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.22%, höher als bei 12.3% aller Schwachstellen.
- Abhilfe: auf 8.0.1 oder neuer aktualisieren.
Description
Impact
When authenticating users PrestaShop preserves session attributes. Because this does not clear CSRF tokens upon login, this might enables same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation.
Patches
The problem is fixed in version 8.0.1
NVD description
PrestaShop is an open source e-commerce web application that, prior to version 8.0.1, is vulnerable to cross-site request forgery (CSRF). When authenticating users, PrestaShop preserves session attributes. Because this does not clear CSRF tokens upon login, this might enable same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation. The problem is fixed in version 8.0.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free