Kurz gesagt
- CVE-2023-40579 ist eine Schwachstelle (MITTEL (CVSS 6.5)) in github.com/openfga/openfga, openfga (openfga).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.55%, höher als bei 45.7% aller Schwachstellen.
- Abhilfe: auf 1.3.1 oder neuer aktualisieren.
Description
Overview
Some end users of OpenFGA v1.3.0 or earlier are vulnerable to authorization bypass when calling the ListObjects API. This means that the API sometimes returns more objects than it should.
Am I Affected?
The vulnerability affects customers using ListObjects with specific models. The affected models contain expressions of type rel1 from type1.
Fix
Update to v1.3.1.
Backward Compatibility
This update is backward compatible.
NVD description
OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. Some end users of OpenFGA v1.3.0 or earlier are vulnerable to authorization bypass when calling the ListObjects API. The vulnerability affects customers using `ListObjects` with specific models. The affected models contain expressions of type `rel1 from type1`. This issue has been patched in version 1.3.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free