Kurz gesagt
- CVE-2024-27090 ist eine Schwachstelle (MITTEL (CVSS 5.3)) in decidim.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.49%, höher als bei 42.3% aller Schwachstellen.
- Abhilfe: auf 0.27.6 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| decidim RubyGems | < 0.27.6
| 0.27.6
|
Description
Impact
If an attacker can infer the slug or URL of an unpublished or private resource, and this resource can be embedded (such as a Participatory Process, an Assembly, a Proposal, a Result, etc), then some data of this resource could be accessed.
Patches
version 0.27.6
https://github.com/decidim/decidim/commit/1756fa639ef393ca8e8bb16221cab2e2e7875705
Workarounds
Disallow access through your web server to the URLs finished with /embed.html
NVD description
Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. If an attacker can infer the slug or URL of an unpublished or private resource, and this resource can be embbeded (such as a Participatory Process, an Assembly, a Proposal, a Result, etc), then some data of this resource could be accessed. This vulnerability is fixed in 0.27.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free