Kurz gesagt
- CVE-2024-42468 ist eine Schwachstelle (HOCH (CVSS 7.5)) in org.openhab.ui.bundles:org.openhab.ui.cometvisu, openhab (openhab).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.81%, höher als bei 57.0% aller Schwachstellen.
- Abhilfe: auf 4.2.1 oder neuer aktualisieren.
Description
openHAB's CometVisuServlet is susceptible to an unauthenticated path traversal vulnerability.
Local files on the server can be requested via HTTP GET on the CometVisuServlet.
This vulnerability was discovered with the help of CodeQL's Uncontrolled data used in path expression query.
Impact
This issue may lead to Information Disclosure.
NVD description
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. CometVisuServlet in versions prior to 4.2.1 is susceptible to an unauthenticated path traversal vulnerability. Local files on the server can be requested via HTTP GET on the CometVisuServlet. This issue may lead to information disclosure. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.
Weitere Schwachstellen in org.openhab.ui.bundles:org.openhab.ui.cometvisu
Alle anzeigen →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free