Kurz gesagt
- CVE-2024-48944 ist eine Schwachstelle (MITTEL (CVSS 6.5)) in org.apache.kylin:kylin-common-server, kylin (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.64%, höher als bei 50.8% aller Schwachstellen.
- Abhilfe: auf 5.0.2 oder neuer aktualisieren.
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. Through a kylin server, an attacker may forge a request to invoke "/kylin/api/xxx/diag" api on another internal host and possibly get leaked information. There are two preconditions: 1) The attacker has got admin access to a kylin server; 2) Another internal host has the "/kylin/api/xxx/diag" api endpoint open for service.
This issue affects Apache Kylin: from 5.0.0 through 5.0.1.
Users are recommended to upgrade to version 5.0.2, which fixes the issue.
NVD description
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. Through a kylin server, an attacker may forge a request to invoke "/kylin/api/xxx/diag" api on another internal host and possibly get leaked information. There are two preconditions: 1) The attacker has got admin access to a kylin server; 2) Another internal host has the "/kylin/api/xxx/diag" api
endpoint open for service.
This issue affects Apache Kylin: from 5.0.0
through
5.0.1.
Users are recommended to upgrade to version 5.0.2, which fixes the issue.
Weitere Schwachstellen in org.apache.kylin:kylin-common-server
Alle anzeigen →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free