Kurz gesagt
- CVE-2024-54676 ist eine Schwachstelle (KRITISCH (CVSS 9.8)) in org.apache.openmeetings:openmeetings-parent, openmeetings (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 68.8%, höher als bei 99.3% aller Schwachstellen.
- Abhilfe: auf 8.0.0 oder neuer aktualisieren.
Description
Vendor: The Apache Software Foundation
Versions Affected: Apache OpenMeetings from 2.1.0 before 8.0.0
Description: Default clustering instructions at https://openmeetings.apache.org/Clustering.html doesn't specify white/black lists for OpenJPA this leads to possible deserialisation of untrusted data.
Users are recommended to upgrade to version 8.0.0 and update their startup scripts to include the relevant 'openjpa.serialization.class.blacklist' and 'openjpa.serialization.class.whitelist' configurations as shown in the documentation.
NVD description
Vendor: The Apache Software Foundation
Versions Affected: Apache OpenMeetings from 2.1.0 before 8.0.0
Description: Default clustering instructions at https://openmeetings.apache.org/Clustering.html doesn't specify white/black lists for OpenJPA this leads to possible deserialisation of untrusted data.
Users are recommended to upgrade to version 8.0.0 and update their startup scripts to include the relevant 'openjpa.serialization.class.blacklist' and 'openjpa.serialization.class.whitelist' configurations as shown in the documentation.
Weitere Schwachstellen in org.apache.openmeetings:openmeetings-parent
Alle anzeigen →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free