Kurz gesagt
- CVE-2026-24012 ist eine Schwachstelle (HOCH (CVSS 7.5)) in apache-iotdb, iotdb (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.74%, höher als bei 54.6% aller Schwachstellen.
- Abhilfe: auf 2.0.8 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| apache-iotdb PyPI | ≥ 1.3.3, < 2.0.8
| 2.0.8
|
| iotdb | ≥ 1.3.3, < 2.0.8
| 2.0.8
|
Description
Uncontrolled Resource Consumption vulnerability in Apache IoTDB.
Some interface fails to impose reasonable
limits on the time span and aggregation interval of the query. An attacker
can construct a request with extreme parameters (e.g., a very large time
range combined with a minimal interval). This forces the DataNode to build
an enormous result set in memory, which exhausts the Java heap and causes
the DataNode process to crash.
This issue affects Apache IoTDB: from 1.3.3 before 2.0.8.
Users are recommended to upgrade to version 2.0.8, which fixes the issue.
NVD description
Uncontrolled Resource Consumption vulnerability in Apache IoTDB.
Some interface fails to impose reasonable
limits on the time span and aggregation interval of the query. An attacker
can construct a request with extreme parameters (e.g., a very large time
range combined with a minimal interval). This forces the DataNode to build
an enormous result set in memory, which exhausts the Java heap and causes
the DataNode process to crash.
This issue affects Apache IoTDB: from 1.3.3 before 2.0.8.
Users are recommended to upgrade to version 2.0.8, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free