Kurz gesagt
- CVE-2026-24013 ist eine Schwachstelle (KRITISCH (CVSS 9.1)) in apache-iotdb, iotdb (apache).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.64%, höher als bei 50.5% aller Schwachstellen.
- Abhilfe: auf 2.0.8 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| apache-iotdb PyPI | ≥ 1.3.3, < 2.0.8
| 2.0.8
|
| iotdb | ≥ 1.3.3, < 2.0.8
| 2.0.8
|
Description
Authentication Bypass by Spoofing vulnerability in Apache IoTDB.
Certain Thrift RPC query handlers lack strict validation of the sessionId
parameter. An attacker can construct requests with a forged sessionId and,
without performing openSession authentication, receive valid query results.
This allows authentication bypass and unauthorized reading of time-series
data.
This issue affects Apache IoTDB: from 1.3.3 before 2.0.8.
Users are recommended to upgrade to version 2.0.8, which fixes the issue.
NVD description
Authentication Bypass by Spoofing vulnerability in Apache IoTDB.
Certain Thrift RPC query handlers lack strict validation of the sessionId
parameter. An attacker can construct requests with a forged sessionId and,
without performing openSession authentication, receive valid query results.
This allows authentication bypass and unauthorized reading of time-series
data.
This issue affects Apache IoTDB: from 1.3.3 before 2.0.8.
Users are recommended to upgrade to version 2.0.8, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free