Kurz gesagt
- CVE-2026-28423 ist eine Schwachstelle (HOCH (CVSS 8.6)) in statamic/cms, statamic (statamic).
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.43%, höher als bei 36.9% aller Schwachstellen.
- Abhilfe: auf 6.4.0, 5.73.11 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| statamic/cms Packagist | ≥ 6.0.0-alpha.1, < 6.4.0< 5.73.11
| 6.4.05.73.11
|
| statamic | ≥ 6.0.0, < 6.4.0< 5.73.11
| 6.4.05.73.11
|
Description
Impact
When Glide image manipulation is used in insecure mode (which is not the default), the image proxy can be abused by an unauthenticated user to make the server send HTTP requests to arbitrary URLs—either via the URL directly or via the watermark feature. That can allow access to internal services, cloud metadata endpoints, and other hosts reachable from the server.
Patches
This has been fixed in 5.73.11 and 6.4.0.
NVD description
Statmatic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.11 and 6.4.0, when Glide image manipulation is used in insecure mode (which is not the default), the image proxy can be abused by an unauthenticated user to make the server send HTTP requests to arbitrary URLs—either via the URL directly or via the watermark feature. That can allow access to internal services, cloud metadata endpoints, and other hosts reachable from the server. This has been fixed in 5.73.11 and 6.4.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free