Kurz gesagt
- CVE-2026-42235 ist eine Schwachstelle (KRITISCH (CVSS 9.6)) in n8n (n8n), n8n.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.33%, höher als bei 26.4% aller Schwachstellen.
- Abhilfe: auf 2.17.4, 1.123.32, 2.18.1 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| n8n | = 2.18.0≥ 2.17.0, < 2.17.4< 1.123.32
| 2.17.41.123.32
|
| n8n npm | ≥ 2.17.0, < 2.17.4≥ 2.18.0, < 2.18.1< 1.123.32
| 2.17.42.18.11.123.32
|
Description
Impact
An unauthenticated attacker could register a malicious MCP OAuth client with a crafted client_name. If a victim user authorized the OAuth consent dialog and a second user subsequently revoked that access, a toast notification would render the injected script. Clicking the link would execute arbitrary JavaScript in the victim's authenticated n8n browser session, enabling credential and session token theft, workflow manipulation, or privilege escalation.
Patches
This issue has been fixed in n8n version 2.14.2. Users should upgrade to this version or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Restrict access to the n8n instance and the MCP OAuth registration endpoint to trusted users only.
- Disable MCP server functionality if it is not actively required.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
NVD description
n8n is an open source workflow automation platform. Prior to versions 1.123.32, 2.17.4, and 2.18.1, an unauthenticated attacker could register a malicious MCP OAuth client with a crafted client_name. If a victim user authorized the OAuth consent dialog and a second user subsequently revoked that access, a toast notification would render the injected script. Clicking the link would execute arbitrary JavaScript in the victim's authenticated n8n browser session, enabling credential and session token theft, workflow manipulation, or privilege escalation. This issue has been patched in versions 1.123.32, 2.17.4, and 2.18.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free