Kurz gesagt
- CVE-2026-45660 ist eine Schwachstelle (MITTEL (CVSS 5.4)) in statamic/cms.
- Wahrscheinlichkeit einer Ausnutzung in den nächsten 30 Tagen (EPSS): 0.15%, höher als bei 4.3% aller Schwachstellen.
- Abhilfe: auf 6.18.1, 5.73.22 oder neuer aktualisieren.
| Package | Affected versions | Patched versions |
|---|
| statamic/cms Packagist | ≥ 6.0.0-alpha.1, < 6.18.1< 5.73.22
| 6.18.15.73.22
|
Description
Impact
The Glide image proxy's URL validation could be bypassed using an IP representation that wasn't normalized before the public-IP check. An unauthenticated user could cause the server to make HTTP requests to internal addresses — including loopback, private network, and cloud metadata endpoints.
This affects sites that pass user-supplied URLs to Glide. Sites running PHP 8.3 or newer are not affected.
Patches
This has been fixed in 5.73.22 and 6.18.1
NVD description
Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.73.22 and 6.18.1, the Glide image proxy's URL validation could be bypassed using an IP representation that wasn't normalized before the public-IP check. An unauthenticated user could cause the server to make HTTP requests to internal addresses — including loopback, private network, and cloud metadata endpoints. This affects sites that pass user-supplied URLs to Glide. Sites running PHP 8.3 or newer are not affected. This vulnerability is fixed in 5.73.22 and 6.18.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free