En resumen
- CVE-2010-2273 es una vulnerabilidad MEDIO (CVSS 4.3) que afecta a dojo (dojotoolkit), dojo.
- Probabilidad de explotación en los próximos 30 días (EPSS): 4.5%, mayor que el 91.6% de las vulnerabilidades.
- Solución: actualizar a 1.10.10, 1.11.6, 1.12.4, 1.13.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| dojo | = 1.0= 1.0.1= 1.0.2= 1.1= 1.1.1= 1.2= 1.2.1= 1.2.2= 1.2.3= 1.3= 1.3.1= 1.3.2= 1.4= 1.4.1
| No fix yet |
| dojo npm | ≥ 1.10.0, < 1.10.10≥ 1.11.0, < 1.11.6≥ 1.12.0, < 1.12.4≥ 1.13.0, < 1.13.1
| 1.10.101.11.61.12.41.13.1
|
Description
Versions of dojo prior to 1.4.2 are vulnerable to DOM-based Cross-Site Scripting (XSS). The package does not sanitize URL parameters in the _testCommon.js and runner.html test files, allowing attackers to execute arbitrary JavaScript in the victim's browser.
Recommendation
Upgrade to version 1.4.2 or later.
NVD description
Multiple cross-site scripting (XSS) vulnerabilities in Dojo 1.0.x before 1.0.3, 1.1.x before 1.1.2, 1.2.x before 1.2.4, 1.3.x before 1.3.3, and 1.4.x before 1.4.2 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors, possibly related to dojo/resources/iframe_history.html, dojox/av/FLAudio.js, dojox/av/FLVideo.js, dojox/av/resources/audio.swf, dojox/av/resources/video.swf, util/buildscripts/jslib/build.js, and util/buildscripts/jslib/buildUtil.js, as demonstrated by the (1) dojoUrl and (2) testUrl parameters to util/doh/runner.html.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free