En resumen
- CVE-2018-3778 es una vulnerabilidad MEDIO (CVSS 5.3) que afecta a aedes (aedes project), aedes.
- Probabilidad de explotación en los próximos 30 días (EPSS): 1.4%, mayor que el 72.9% de las vulnerabilidades.
- Solución: actualizar a 0.35.0, 0.35.1 o posterior.
| Package | Affected versions | Patched versions |
|---|
| aedes | < 0.35.0
| 0.35.0
|
| aedes npm | < 0.35.1
| 0.35.1
|
Description
Versions of aedes before 0.35.1 does not respect its own authorization rules when a client sets a Last Will.
Recommendation
Update to version 0.35.1 or later.
NVD description
Improper authorization in aedes version <0.35.0 will publish a LWT in a channel when a client is not authorized.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free