En resumen
- CVE-2019-5417 es una vulnerabilidad ALTO (CVSS 7.5) que afecta a serve (zeit), serve.
- Probabilidad de explotación en los próximos 30 días (EPSS): 2.3%, mayor que el 83.1% de las vulnerabilidades.
- Solución: actualizar a 7.3.1, 7.1.3 o posterior.
| Package | Affected versions | Patched versions |
|---|
| serve | ≥ 7.0.1, < 7.3.1
| 7.3.1
|
| serve npm | < 7.1.3
| 7.1.3
|
Description
Versions of serve before 7.1.3 are vulnerable to Directory Traversal. File paths are not sanitized leading to unauthorized access of system files.
Recommendation
Upgrade to version 7.1.3 or later
NVD description
A path traversal vulnerability in serve npm package version 7.0.1 allows the attackers to read content of arbitrary files on the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free